minor cleanup
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 Feb 2007 00:52:51 +0000 (00:52 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 Feb 2007 00:52:51 +0000 (00:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6381 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/alsa/Makefile

index 8aa80e74a5c75f6781ed094eeae68ca2e466562e..347ef76276a8f0c11e6599796fedbdd9beca5d81 100644 (file)
@@ -46,21 +46,18 @@ ifeq ($(LINUX_KARCH),mips)
   KERNEL_C_INCS:= -I$(LINUX_DIR)/include/asm-mips/mach-generic
 endif
 
-define Build/Configure
-       (cd $(PKG_BUILD_DIR); \
-               CFLAGS="$(KERNEL_C_INCS)" \
-               ./configure \
-                       --with-build="$(LINUX_DIR)" \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --with-cross="$(KERNEL_CROSS)" \
-                       --with-redhat=no \
-                       --with-suse=no \
-                       --with-oss=yes \
-                       --with-isapnp=no \
-                       --with-sequencer=no \
-                       --with-cards=usb-audio \
-       );
-endef
+CONFIGURE_VARS:= \
+       CFLAGS="$(KERNEL_C_INCS)"
+
+CONFIGURE_ARGS:= \
+       --with-build="$(LINUX_DIR)" \
+       --with-kernel="$(LINUX_DIR)" \
+       --with-redhat=no \
+       --with-suse=no \
+       --with-oss=yes \
+       --with-isapnp=no \
+       --with-sequencer=no \
+       --with-cards=usb-audio
 
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \