detect quilt configure errors properly (their broken configure script does not return...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2009 19:02:48 +0000 (19:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2009 19:02:48 +0000 (19:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14181 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/quilt/Makefile

index 49da92b7344f81ae5101baee49cf6120a3fe9a00..5294534b017552ba16ca8523abf95cd85fc5f58f 100644 (file)
@@ -15,6 +15,11 @@ PKG_MD5SUM:=d33d2442bd34387260b1c1db3e623af0
 
 include $(INCLUDE_DIR)/host-build.mk
 
+define Build/Configure
+       $(call Build/Configure/Default)
+       [ -f $(PKG_BUILD_DIR)/Makefile ]
+endef
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) SHELL="$(BASH)"
 endef