Fix the watchdog path for the SCX200 watchdog driver
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Mar 2008 16:50:07 +0000 (16:50 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Mar 2008 16:50:07 +0000 (16:50 +0000)
Signed-off-by: Roberto Riggio <roberto.riggio@create-net.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10672 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index a3ce6e9f1cfdda1a30d81ac8f374bb601525accd..11c45136d3454c1578b5c88bee9f3c615e260486 100644 (file)
@@ -454,7 +454,7 @@ define KernelPackage/scx200-wdt
   TITLE:=Natsemi SCX200 Watchdog support
   DEPENDS:=@TARGET_x86
   KCONFIG:=CONFIG_SC1200_WDT
-  FILES:=$(LINUX_DIR)/drivers/char/watchdog/scx200_wdt.$(LINUX_KMOD_SUFFIX)
+  FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/scx200_wdt.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,50,scx200_wdt)
 endef