fix mtd-utils compile on freebsd
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 16:51:25 +0000 (16:51 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 16:51:25 +0000 (16:51 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5020 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/include/endian.h
tools/mtd-utils/Makefile

index 4ea34cdd0f95c354ebc15bae00c54fb249f18db1..9bfc652b908bf0e6697226bc32366c66beebdfaa 100644 (file)
@@ -9,6 +9,11 @@
 #define bswap_16(x) NXSwapShort(x)
 #define bswap_32(x) NXSwapInt(x)
 #define bswap_64(x) NXSwapLongLong(x)
+#elif defined(__FreeBSD__)
+#include <sys/endian.h>
+#define bswap_16(x) bswap16(x)
+#define bswap_32(x) bswap32(x)
+#define bswap_64(x) bswap64(x)
 #else
 #include <machine/endian.h>
 #define bswap_16(x) swap16(x)
index 55dd88a785101171b84be0b0e4ea7a9d37972e35..f67ccf758fb4fc2bd8e0b483d4fb00d8ad15b10f 100644 (file)
@@ -20,7 +20,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 CFLAGS := $(HOSTCFLAGS) -O2 -I../include
 ifneq ($(OS),Linux)
-CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h
+CFLAGS += -Dloff_t=off_t -D__BYTE_ORDER=BYTE_ORDER -I$(STAGING_DIR)/include-host -include getline.h -include endian.h
 endif
 
 define Build/Compile