[brcm-2.4] allow sta mode to work with psk+aes (#4687)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 May 2009 10:30:55 +0000 (10:30 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 22 May 2009 10:30:55 +0000 (10:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15983 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/broadcom-wl/Makefile
package/broadcom-wl/files/lib/wifi/broadcom.sh

index 5317e0d430d54cf6c64d910a20c1d80ac23354ff..ce543746751216feb58f02d3942cb4f7e353de68 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=4.150.10.5.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 WLC_VERSION:=0.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 998a2f58ff7dd00588d63b4040359e2bb2d66f8b..9ce49ab6fbaddbbadc09b232fa9d0be8394929bf 100644 (file)
@@ -199,6 +199,7 @@ enable_broadcom() {
                                case "$enc" in
                                        wpa*+wpa2*|WPA*+WPA2*|*psk+*psk2|*PSK+*PSK2) auth=132; wsec=6;;
                                        wpa2*|WPA2*|*PSK2|*psk2) auth=128; wsec=4;;
+                                       *aes|*AES) auth=4; wsec=4;;
                                        *) auth=4; wsec=2;;
                                esac
                                eval "${vif}_key=\"\$key\""