[package] broadcom-wl: move txpower back to wifi-device section, but remain backwards...
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jan 2009 16:08:19 +0000 (16:08 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 31 Jan 2009 16:08:19 +0000 (16:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14306 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/broadcom-wl/Makefile
package/broadcom-wl/files/lib/wifi/broadcom.sh

index 345f84999486cc3afe11dc6bc3e0e06057b46e46..e49fc50a880b3eb7d31e72827178c182f6f5b150 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=broadcom-wl
 PKG_VERSION:=4.150.10.5.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 WLC_VERSION:=0.1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 4c03aff04c633b2b53fa0d874bbecc59f5ab4b7a..12002121a63af4f6a7019e038dcc924b393b99b3 100644 (file)
@@ -123,7 +123,8 @@ enable_broadcom() {
        config_get macfilter "$device" macfilter
        config_get maclist "$device" maclist
        config_get macaddr "$device" macaddr
-       local vif_pre_up vif_post_up vif_do_up txpower
+       config_get txpower "$device" txpower
+       local vif_pre_up vif_post_up vif_do_up vif_txpower
 
        _c=0
        nas="$(which nas)"
@@ -152,7 +153,7 @@ enable_broadcom() {
        esac
 
        for vif in $vifs; do
-               config_get txpower "$vif" txpower
+               config_get vif_txpower "$vif" txpower
 
                config_get mode "$vif" mode
                append vif_pre_up "vif $_c" "$N"
@@ -305,7 +306,11 @@ EOF
        wlc stdin <<EOF
 $vif_do_up
 EOF
-       [ -z "$txpower" ] || iwconfig $device txpower ${txpower}dBm 
+
+       # use vif_txpower (from last wifi-iface) instead of txpower (from
+       # wifi-device) if the latter does not exist
+       txpower=${txpower:-$vif_txpower}
+       [ -z "$txpower" ] || iwconfig $device txpower ${txpower}dBm
 
        eval "$nas_cmd"
 }