add 0xdeadc0de to the jffs2 filesystem images
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Jun 2006 00:59:47 +0000 (00:59 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 22 Jun 2006 00:59:47 +0000 (00:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4048 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index f30f0997eee1fe3ca7c1810385d26fc2d93e7b36..bf80e27990239b4a53263e34903f111ce5aa3ffc 100644 (file)
@@ -17,6 +17,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x10000 -o $(KDIR)/root.jffs2-64k -d $(BUILD_DIR)/root
                $(STAGING_DIR)/bin/mkfs.jffs2 $(JFFS2OPTS) -e 0x20000 -o $(KDIR)/root.jffs2-128k -d $(BUILD_DIR)/root
+
+               # add End-of-Filesystem markers
+               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-64k
+               echo -ne '\xde\xad\xc0\xde' >> $(KDIR)/root.jffs2-128k
        
                $(call Image/Build,jffs2-64k)
                $(call Image/Build,jffs2-128k)