fix menuconfig
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Apr 2007 11:03:05 +0000 (11:03 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Apr 2007 11:03:05 +0000 (11:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6881 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index fffc3bf5dab101e2cee4ed0d8d98d5daeda5164d..d7e4585595c023c96a683f91505d7652abed486d 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -90,9 +90,9 @@ oldconfig: scripts/config/conf tmp/.config-target.in tmp/.config-package.in FORC
        $< -o Config.in
 
 menuconfig: scripts/config/mconf tmp/.config-target.in tmp/.config-package.in FORCE
-       @[ -f .config ] || { \
-               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
-       }
+       @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \
+               cp $(HOME)/.openwrt/defconfig .config; \
+       fi
        $< Config.in
 
 kernel_menuconfig: .config FORCE