add md5sums for binutils & gcc and use the GNU mirror facility
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Nov 2008 21:18:33 +0000 (21:18 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Nov 2008 21:18:33 +0000 (21:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13143 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/binutils/Makefile
toolchain/gcc/Makefile

index 2a881f83d4c7b9e005959b20dca912b4218511c7..e6745da8eb24bab663218defbf05d8e519635878 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,15 +9,21 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=binutils
 PKG_VERSION:=$(call qstrip,$(CONFIG_BINUTILS_VERSION))
 
-PKG_SOURCE_URL:=http://ftp.gnu.org/gnu/binutils/ \
-       ftp://gatekeeper.dec.com/pub/GNU/ \
-        ftp://ftp.uu.net/archive/systems/gnu/ \
-        ftp://ftp.eu.uu.net/pub/gnu/ \
-        ftp://ftp.funet.fi/pub/gnu/prep/ \
-        ftp://ftp.leo.org/pub/comp/os/unix/gnu/ 
+PKG_SOURCE_URL:=@GNU/binutils/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+ifeq ($(PKG_VERSION),2.16.1)
+  PKG_MD5SUM:=6a9d529efb285071dad10e1f3d2b2967
+endif
+ifeq ($(PKG_VERSION),2.17)
+  PKG_MD5SUM:=e26e2e06b6e4bf3acf1dc8688a94c0d1
+endif
+ifeq ($(PKG_VERSION),2.18)
+  PKG_MD5SUM:=9d22ee4dafa3a194457caf4706f9cf01
+endif
 
-PKG_SOURCE:=binutils-$(PKG_VERSION).tar.bz2
 PATCH_DIR:=./patches/$(PKG_VERSION)
+
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 override CONFIG_AUTOREBUILD=
index be4848b0774d7a6ea4ee119b90ee416b13ed60e6..adf665fc41d2feab042369bcccb930d527eb872b 100644 (file)
@@ -23,11 +23,33 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=gcc
 PKG_VERSION:=$(call qstrip,$(CONFIG_GCC_VERSION))
 
+PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+
+ifeq ($(PKG_VERSION),3.4.6)
+  PKG_MD5SUM:=4a21ac777d4b5617283ce488b808da7b
+endif
+ifeq ($(PKG_VERSION),4.1.2)
+  PKG_MD5SUM:=a4a3eb15c96030906d8494959eeda23c
+endif
+ifeq ($(PKG_VERSION),4.2.0)
+  PKG_MD5SUM:=4798c23548dc791ea12a139e18940684
+endif
+ifeq ($(PKG_VERSION),4.2.1)
+  PKG_MD5SUM:=cba410e6ff70f7d7f4be7a0267707fd0
+endif
+ifeq ($(PKG_VERSION),4.2.2)
+  PKG_MD5SUM:=7ae33781417a35a2eb03ee098a9f4490
+endif
+ifeq ($(PKG_VERSION),4.2.3)
+  PKG_MD5SUM:=ef2a4d9991b3644115456ea05b2b8163
+endif
+ifeq ($(PKG_VERSION),4.2.4)
+  PKG_MD5SUM:=d79f553e7916ea21c556329eacfeaa16
+endif
+
 PATCH_DIR=./patches/$(PKG_VERSION)
-PKG_SOURCE_URL:=ftp://ftp.fu-berlin.de/unix/languages/gcc/releases/gcc-$(PKG_VERSION) \
-       http://mirrors.rcn.net/pub/sourceware/gcc/releases/gcc-$(PKG_VERSION) \
-       ftp://ftp.gnu.org/gnu/gcc/releases/gcc-$(PKG_VERSION)
-PKG_SOURCE:=gcc-$(PKG_VERSION).tar.bz2
+
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 override CONFIG_AUTOREBUILD=