backfire: ImageBuilder: respect the PROFILE parameter (backport of r29877)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jan 2012 18:08:02 +0000 (18:08 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Jan 2012 18:08:02 +0000 (18:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29892 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/files/Makefile

index e8d282a8f0cbd6c0055ef0d313034bb806b82b5d..f74b40789619d62ea31ac10a56a4362c3bfee3c2 100644 (file)
@@ -38,7 +38,7 @@ Building images:
        By default 'make image' will create an image with the default
        target profile and package set. You can use the following parameters
        to change that:
        By default 'make image' will create an image with the default
        target profile and package set. You can use the following parameters
        to change that:
-       
+
        make image PROFILE="<profilename>" # override the default target profile
        make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make image FILES="<path>" # include extra files from <path>
        make image PROFILE="<profilename>" # override the default target profile
        make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make image FILES="<path>" # include extra files from <path>
@@ -113,7 +113,7 @@ ifneq ($(USER_FILES),)
 endif
        $(MAKE) package_postinst
        $(MAKE) build_image
 endif
        $(MAKE) package_postinst
        $(MAKE) build_image
-       
+
 package_index: FORCE
        @echo
        @echo Building package index...
 package_index: FORCE
        @echo
        @echo Building package index...
@@ -152,8 +152,9 @@ package_postinst: FORCE
 build_image: FORCE
        @echo
        @echo Building images...
 build_image: FORCE
        @echo
        @echo Building images...
-       $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1
-       
+       $(NO_TRACE_MAKE) -C target/linux/$(BOARD)/image install TARGET_BUILD=1 IB=1 \
+               $(if $(USER_PROFILE),PROFILE="$(USER_PROFILE)")
+
 clean:
        rm -rf $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR) $(BIN_DIR)
 
 clean:
        rm -rf $(TOPDIR)/tmp $(TOPDIR)/dl $(TARGET_DIR) $(BIN_DIR)