fix path to temporary files
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Nov 2006 01:38:24 +0000 (01:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Nov 2006 01:38:24 +0000 (01:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5502 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile

index d1605afe9f9fd1d23c0eaf3f77bb503ec1f836d0..e0483deb59e7414cdff5e9e495718ac5e4187c41 100644 (file)
@@ -8,7 +8,7 @@
 
 include $(TOPDIR)/rules.mk
 include $(TOPDIR)/.config
-include $(TOPDIR)/.pkgdeps
+include $(TMP_DIR)/.pkgdeps
 include $(INCLUDE_DIR)/host.mk
 
 PREREQ_PACKAGES:=$(patsubst %,%-prereq,$(prereq-y) $(prereq-m))
@@ -41,7 +41,7 @@ ifeq ($(SDK),1)
 GENDEP_OPTS := -s
 endif
 
-$(TOPDIR)/.pkgdeps: $(TOPDIR)/.pkginfo
+$(TMP_DIR)/.pkgdeps: $(TMP_DIR)/.pkginfo
        @$(TOPDIR)/scripts/gen_deps.pl $(GENDEP_OPTS) < $< > $@ || rm -f $@
 
 all: compile