[tools] update mpfr to 2.4.1
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Aug 2009 16:08:52 +0000 (16:08 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 20 Aug 2009 16:08:52 +0000 (16:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17334 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/mpfr/Makefile
tools/mpfr/patches/001-no_tests.patch

index 17734a246a0e3944b2f336392eee72980f187ba5..c41cc66b5c273b7eb912db50cebe3e7e22dfd813 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mpfr
-PKG_VERSION:=2.3.2
+PKG_VERSION:=2.4.1
 
-PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-2.3.2
+PKG_SOURCE_URL:=http://www.mpfr.org/mpfr-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=527147c097874340cb9cee0579dacf3b
+PKG_MD5SUM:=
 
 include $(INCLUDE_DIR)/host-build.mk
 
index ef644c1d67c74f7ad6b2711ba91b3a3ca7adae82..e1a6f05c12bec1c508cd5eb88498307c64efa72a 100644 (file)
@@ -1,23 +1,24 @@
-diff -urN mpfr-2.3.2/Makefile.am mpfr-2.3.2.new/Makefile.am
---- mpfr-2.3.2/Makefile.am     2008-09-12 15:47:25.000000000 +0200
-+++ mpfr-2.3.2.new/Makefile.am 2009-08-17 15:19:18.000000000 +0200
-@@ -1,6 +1,6 @@
+diff -urN mpfr-2.4.1/Makefile.am mpfr-2.4.1.new/Makefile.am
+--- mpfr-2.4.1/Makefile.am     2009-02-20 10:43:17.000000000 +0100
++++ mpfr-2.4.1.new/Makefile.am 2009-08-20 14:59:00.000000000 +0200
+@@ -1,7 +1,7 @@
  AUTOMAKE_OPTIONS = gnu ansi2knr
+ ACLOCAL_AMFLAGS = -I m4
  
 -SUBDIRS = tests
-+SUBDIRS = 
- EXTRA_DIST = BUGS FAQ.html PATCHES VERSION get_patches.sh generic.c round_raw_generic.c gen_inverse.h jyn_asympt.c
++SUBDIRS =
+ EXTRA_DIST = BUGS FAQ.html PATCHES VERSION get_patches.sh round_raw_generic.c gen_inverse.h jyn_asympt.c
  
  include_HEADERS = mpfr.h mpf2mpfr.h
-diff -urN mpfr-2.3.2/Makefile.in mpfr-2.3.2.new/Makefile.in
---- mpfr-2.3.2/Makefile.in     2008-09-12 15:48:04.000000000 +0200
-+++ mpfr-2.3.2.new/Makefile.in 2009-08-17 15:19:12.000000000 +0200
-@@ -283,7 +283,7 @@
- top_builddir = @top_builddir@
+diff -urN mpfr-2.4.1/Makefile.in mpfr-2.4.1.new/Makefile.in
+--- mpfr-2.4.1/Makefile.in     2009-02-25 17:18:06.000000000 +0100
++++ mpfr-2.4.1.new/Makefile.in 2009-08-20 14:58:32.000000000 +0200
+@@ -295,7 +295,7 @@
  top_srcdir = @top_srcdir@
  AUTOMAKE_OPTIONS = gnu ansi2knr
+ ACLOCAL_AMFLAGS = -I m4
 -SUBDIRS = tests
-+SUBDIRS = 
- EXTRA_DIST = BUGS FAQ.html PATCHES VERSION get_patches.sh generic.c round_raw_generic.c gen_inverse.h jyn_asympt.c
++SUBDIRS =
+ EXTRA_DIST = BUGS FAQ.html PATCHES VERSION get_patches.sh round_raw_generic.c gen_inverse.h jyn_asympt.c
  include_HEADERS = mpfr.h mpf2mpfr.h
  lib_LTLIBRARIES = libmpfr.la