same as [6881]
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Apr 2007 11:53:18 +0000 (11:53 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Apr 2007 11:53:18 +0000 (11:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6882 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index d7e4585595c023c96a683f91505d7652abed486d..cab2486fb162c027a84f4e1d5329933bdc62c3e0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -62,10 +62,10 @@ tmp/.config-%.in: tmp/.%info
 
 
 .config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
-       @[ -f .config ] || { \
-               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
+       @if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \ 
+               cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig; \
-       }
+       fi
        @$< -D .config Config.in &> /dev/null
 
 scripts/config/mconf: