imagebuilder: add REVISION variable (closes #6795)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Mar 2010 17:00:46 +0000 (17:00 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 8 Mar 2010 17:00:46 +0000 (17:00 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20064 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/imagebuilder/Makefile
target/imagebuilder/files/Makefile

index d0b6b88b2e6f6f2d4de448d5a54a38577a9ad4ca..923c1e94b786a6ba8860d55960433405550c3a99 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -38,6 +38,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
                $(PKG_BUILD_DIR)/target/linux/*/patches \
                $(PKG_BUILD_DIR)/target/linux/*/*/patches
        -cp $(KERNEL_BUILD_DIR)/* $(IB_KDIR)/ # don't copy subdirectories here
+       echo REVISION:="$(REVISION)" > $(PKG_BUILD_DIR)/include/version.mk
        find $(PKG_BUILD_DIR) -name .svn | $(XARGS) rm -rf
        find $(PKG_BUILD_DIR) -name CVS | $(XARGS) rm -rf
        find $(PKG_BUILD_DIR) -name .git | $(XARGS) rm -rf
index f73642b6ad6fcc7b66f33d5ef18f4e4326f4ae2b..49fd6db949c0b44b862845b14a407cdb19c603f4 100644 (file)
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -24,6 +24,9 @@ include rules.mk
 include $(INCLUDE_DIR)/debug.mk
 include $(INCLUDE_DIR)/depends.mk
 
+include $(INCLUDE_DIR)/version.mk
+export REVISION
+
 define Helptext
 Available Commands:
        help:   This help text