bcm963xx: add missing trailing zero to load address
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 May 2008 17:31:11 +0000 (17:31 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 May 2008 17:31:11 +0000 (17:31 +0000)
The load address for BCM963xx is 0x80010000, not 0xf8001000 as in the current
sources. I think this is just a typo, so this patch fixes it (tested on 96345).

Signed-off-by: Axel Gembe <ago@bastart.eu.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11177 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/patches-2.6.25/050-bcm963xx_add_trailing_zero.patch [new file with mode: 0644]

diff --git a/target/linux/brcm63xx/patches-2.6.25/050-bcm963xx_add_trailing_zero.patch b/target/linux/brcm63xx/patches-2.6.25/050-bcm963xx_add_trailing_zero.patch
new file mode 100644 (file)
index 0000000..fee0112
--- /dev/null
@@ -0,0 +1,29 @@
+From 40dd38388c3d1c87efe254cee533fc5db5ffc4ed Mon Sep 17 00:00:00 2001
+From: Axel Gembe <ago@bastart.eu.org>
+Date: Wed, 14 May 2008 12:43:34 +0200
+Subject: [PATCH] bcm963xx: add missing trailing zero to load address
+
+The load address for BCM963xx is 0x80010000, not 0xf8001000 as in the current
+sources. I think this is just a typo, so this patch fixes it (tested on 96345).
+
+Signed-off-by: Axel Gembe <ago@bastart.eu.org>
+---
+ arch/mips/Makefile |    2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/arch/mips/Makefile b/arch/mips/Makefile
+index 16a29e1..6551951 100644
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -562,7 +562,7 @@ load-$(CONFIG_BCM47XX)             := 0xffffffff80001000
+ core-$(CONFIG_BCM963XX)               += arch/mips/bcm963xx/
+ cflags-$(CONFIG_BCM963XX)     += -Iinclude/asm-mips/mach-bcm963xx
+-load-$(CONFIG_BCM963XX)               := 0xffffffff8001000
++load-$(CONFIG_BCM963XX)               := 0xffffffff80010000
+ #
+ # SNI RM
+-- 
+1.5.5.1
+