explicitely disable a bunch of package on ar7 until we properly detect pci & usb...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Apr 2008 02:08:11 +0000 (02:08 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 15 Apr 2008 02:08:11 +0000 (02:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10839 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mac80211/Makefile
package/madwifi/Makefile
package/p54/Makefile

index 9370b1d113597386b7b0f102e6094d12b67dd834..749c8c1714f1ac2769732de0ccc817b76e777880 100644 (file)
@@ -19,6 +19,8 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
 
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
+
 define KernelPackage/mac80211
   SUBMENU:=Wireless Drivers
   TITLE:=Linux 802.11 Wireless Networking Stack
@@ -54,7 +56,7 @@ $(eval $(call Download,rt71w))
 define KernelPackage/rt2x00/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Ralink Drivers for RT2x00 cards
-  DEPENDS:=@LINUX_2_6_24 @!TARGET_atheros @!TARGET_uml
+  DEPENDS:=@LINUX_2_6_24 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
 endef
 
 define KernelPackage/rt2x00-lib
index f2fdac7b9d7f6a665ad49e2e27cbc558528e2cd5..d502e33f5946b5b4aabda591c40583c32aff17ab 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -59,7 +59,7 @@ else
 endif
 
 # XXX: remove this check later when we have PCI support properly detected on all targets
-ifneq ($(CONFIG_TARGET_uml),)
+ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
  BUS:=
 endif
 
@@ -108,7 +108,7 @@ define KernelPackage/madwifi
   SUBMENU:=Wireless Drivers
   TITLE:=Driver for Atheros wireless chipsets
   URL:=http://madwifi.org/
-  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
+  DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_ar7 @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
   FILES:=$(MADWIFI_FILES)
   AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
 endef
index c282a09bf11e5292f2d2d9a23a228bd6583c93bb..df2e40433be14c66b14cdd8faf9ffc4a0c9eda06 100644 (file)
@@ -1,10 +1,10 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 # 
-# $Id$
+# $Id$
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
@@ -18,10 +18,12 @@ PKG_FWP54_MD5SUM:=09f9da7ea757173c9de1a0322a1f9782
 
 include $(INCLUDE_DIR)/package.mk
 
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
+
 define KernelPackage/p54/Default
   SUBMENU:=Wireless Drivers
   TITLE:=Prism Wireless Support (mac80211)
-  DEPENDS:=+kmod-mac80211 @!TARGET_atheros @!TARGET_uml
+  DEPENDS:=+kmod-mac80211 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
 endef
 
 define KernelPackage/p54-common