sync dnsmasq with whiterussian
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Jul 2005 08:11:12 +0000 (08:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Jul 2005 08:11:12 +0000 (08:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1556 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dnsmasq/Makefile
package/dnsmasq/files/S50dnsmasq [new file with mode: 0755]
package/dnsmasq/files/dnsmasq.conf [new file with mode: 0644]
package/dnsmasq/ipkg/dnsmasq.conffiles [new file with mode: 0644]

index 5d7133fd1e920d1b4be1302680818505df86a3ad..73a9061353c15a21ee39193688169d670e60af03 100644 (file)
@@ -4,7 +4,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MD5SUM:=b38f33cd0703fa664a37a4595d918189
 
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
@@ -26,8 +26,11 @@ $(PKG_BUILD_DIR)/.built:
        touch $@
 
 $(IPKG_DNSMASQ):
-       mkdir -p $(IDIR_DNSMASQ)/usr/sbin
+       install -d -m0755 $(IDIR_DNSMASQ)/usr/sbin
        cp $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(IDIR_DNSMASQ)/usr/sbin/
        $(STRIP) $(IDIR_DNSMASQ)/usr/sbin/*
+       install -d -m0755 $(IDIR_DNSMASQ)/etc/init.d/
+       install -m0644 ./files/dnsmasq.conf $(IDIR_DNSMASQ)/etc/dnsmasq.conf
+       install -m0755 ./files/S50dnsmasq $(IDIR_DNSMASQ)/etc/init.d/S50dnsmasq
        $(IPKG_BUILD) $(IDIR_DNSMASQ) $(PACKAGE_DIR)
 
diff --git a/package/dnsmasq/files/S50dnsmasq b/package/dnsmasq/files/S50dnsmasq
new file mode 100755 (executable)
index 0000000..4f37218
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh
+. /etc/functions.sh
+
+# interface to use for DHCP
+iface=lan
+
+ifname=$(nvram get ${iface}_ifname)
+ipaddr=$(nvram get ${iface}_ipaddr)
+netmask=$(nvram get ${iface}_netmask)
+
+# check for existing DHCP server
+udhcpc -n -q -R -s /bin/true -i $ifname >&- || {
+
+  ipaddr=$(ip2int $ipaddr)
+  netmask=$(ip2int ${netmask:-255.255.255.0})
+  network=$((ipaddr&netmask))
+  
+  start=$(nvram get dhcp_start)
+  start=$((network+${start:-100}))
+  end=$(nvram get dhcp_num)
+  end=$((start+${end:-150}))
+  
+  args="-l /tmp/dhcp.leases -K -F $(int2ip $start),$(int2ip $end),$(int2ip $netmask),12h"
+}
+dnsmasq ${args}
diff --git a/package/dnsmasq/files/dnsmasq.conf b/package/dnsmasq/files/dnsmasq.conf
new file mode 100644 (file)
index 0000000..4ef9680
--- /dev/null
@@ -0,0 +1,25 @@
+# filter what we send upstream
+domain-needed
+bogus-priv
+filterwin2k
+localise-queries
+
+# allow /etc/hosts and dhcp lookups via *.lan
+local=/lan/
+domain=lan
+
+# no dhcp / dns queries from the wan
+except-interface=vlan1
+
+# enable dhcp (start,end,netmask,leasetime)
+dhcp-authoritative
+#dhcp-range=192.168.1.100,192.168.1.250,255.255.255.0,12h
+#dhcp-leasefile=/tmp/dhcp.leases
+
+# use /etc/ethers for static hosts; same format as --dhcp-host
+# <hwaddr> [<hostname>] <ipaddr>
+read-ethers
+
+# other useful options:
+# default route(s): dhcp-option=3,192.168.1.1,192.168.1.2
+#    dns server(s): dhcp-option=6,192.168.1.1,192.168.1.2
diff --git a/package/dnsmasq/ipkg/dnsmasq.conffiles b/package/dnsmasq/ipkg/dnsmasq.conffiles
new file mode 100644 (file)
index 0000000..e30eba8
--- /dev/null
@@ -0,0 +1 @@
+/etc/dnsmasq.conf