[backfire] merge r27779
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Jul 2011 10:49:46 +0000 (10:49 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 26 Jul 2011 10:49:46 +0000 (10:49 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@27780 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/linux-atm/Makefile
package/lua/Makefile

index fd92cc1fff2adf1ffd885a5671fc28f94fabee08..79781981e84c5cd87e481caf34b13410ad94f5a9 100644 (file)
@@ -48,6 +48,7 @@ define Build/Configure
 endef
 
 TARGET_CFLAGS += -I$(LINUX_DIR)/include -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include
 endef
 
 TARGET_CFLAGS += -I$(LINUX_DIR)/include -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include
+unexport PREFIX
 
 define Build/Compile
        # src/qgen is built with HOSTCC, which does not really like our LDFLAGS
 
 define Build/Compile
        # src/qgen is built with HOSTCC, which does not really like our LDFLAGS
index fdbbddc4015502ce169350804fa437f8609d4d03..55329cd3c77c44901a401c2bb707345b364590f9 100644 (file)
@@ -86,7 +86,7 @@ endef
 define Build/Configure
 endef
 
 define Build/Configure
 endef
 
-TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
+TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99 -ggdb3
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)