fix ppp compile on osx
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 Sep 2006 17:33:45 +0000 (17:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 Sep 2006 17:33:45 +0000 (17:33 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4869 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ppp/Makefile
package/ppp/patches/010-use_target_for_configure.patch [new file with mode: 0644]

index 680076857eb255c4c79985656b3e10545c88cf71..b5a317bd03efc25cb592492fc84a871f7f0a7bbc 100644 (file)
@@ -23,6 +23,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 PKG_BUILDDEP:=libpcap linux-atm
 
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 define Package/ppp/Default
   SECTION:=net
@@ -91,6 +92,14 @@ define Package/pppstats
        This package contains an utility to report PPP statistics.
 endef
 
+define Build/Configure
+$(call Build/Configure/Default,, \
+       UNAME_S="Linux" \
+       UNAME_R="$(LINUX_VERSION)" \
+       UNAME_M="$(ARCH)" \
+)
+endef
+
 define Build/Compile
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)/usr
diff --git a/package/ppp/patches/010-use_target_for_configure.patch b/package/ppp/patches/010-use_target_for_configure.patch
new file mode 100644 (file)
index 0000000..56439a6
--- /dev/null
@@ -0,0 +1,20 @@
+
+       Use values exported from $(TOPDIR)/rules.mk for determining
+       the target system instead of the host configuration
+
+--- ppp-2.4.3/configure.orig   Sat Nov  6 11:36:32 2004
++++ ppp-2.4.3/configure        Sun Jun 18 23:40:46 2006
+@@ -8,9 +8,9 @@ SYSCONF=/etc
+ #  if [ -d /NextApps ]; then
+ #    system="NeXTStep"
+ #  else
+-  system=`uname -s`
+-  release=`uname -r`
+-  arch=`uname -m`
++  system=${UNAME_S:-`uname -s`}
++  release=${UNAME_R:-`uname -r`}
++  arch=${UNAME_M:-`uname -m`}
+ #  fi
+ state="unknown"
+