backport the autoreconf fixup (not enabled by default unless the package makefile...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Dec 2010 15:06:31 +0000 (15:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 10 Dec 2010 15:06:31 +0000 (15:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@24416 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index c941a4949d09a0f1d8a036b4c709e81f54f49b19..245c76842d74564910099dd31544ab7e4c60ce25 100644 (file)
@@ -49,6 +49,24 @@ define remove_version_check
        fi
 endef
 
+define autoreconf
+       (cd $(PKG_BUILD_DIR); \
+               $(patsubst %,rm -f %;,$(PKG_REMOVE_FILES)) \
+               if [ -x ./autogen.sh ]; then \
+                       ./autogen.sh || true; \
+               elif [ -f ./configure.ac ] || [ -f ./configure.in ]; then \
+                       [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                       $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               -B $(STAGING_DIR)/host/share/aclocal \
+                               $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
+               fi \
+       );
+endef
+
+ifneq ($(filter autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf
+endif
+
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
   PKG_BUILD_DEPENDS += libtool
   Hooks/Configure/Pre += update_libtool remove_version_check