use lazy evaluation for TARGET_CONFIGURE_OPTS to make it possible to override TARGET_...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Mar 2010 00:05:48 +0000 (00:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 29 Mar 2010 00:05:48 +0000 (00:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20566 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk

index c1ff95c0a58efa26bc9198285d2beb2079bf17f1..f913d9856a030d7a8271512b76eb8b5afc6fd6bb 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -172,7 +172,7 @@ ifneq ($(CONFIG_CCACHE),)
   TARGET_CC:= ccache $(TARGET_CC)
 endif
 
-TARGET_CONFIGURE_OPTS:= \
+TARGET_CONFIGURE_OPTS = \
   AR=$(TARGET_CROSS)ar \
   AS="$(TARGET_CC) -c $(TARGET_CFLAGS)" \
   LD=$(TARGET_CROSS)ld \