madwifi: select the right hal binary for EABI on ARM
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Sep 2008 23:27:27 +0000 (23:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 5 Sep 2008 23:27:27 +0000 (23:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12540 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/Makefile

index 68bec3014a8b08fc82b2387ffd40cb02d38eb2a4..a0934691eaa0f853d3bfda14f99c053fb1cdb41c 100644 (file)
@@ -76,19 +76,19 @@ ifeq ($(ARCH),i686)
   HAL_TARGET:=i386-elf
 endif
 ifeq ($(BOARD),ixp4xx)
-  HAL_TARGET:=xscale-be-elf
+  HAL_TARGET:=xscale-be-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifeq ($(BOARD),iop32x)
-  HAL_TARGET:=xscale-le-elf
+  HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifeq ($(BOARD),orion)
-  HAL_TARGET:=xscale-le-elf
+  HAL_TARGET:=xscale-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifeq ($(ARCH),powerpc)
   HAL_TARGET:=powerpc-be-elf
 endif
 ifeq ($(BOARD),storm)
-  HAL_TARGET:=armv4-le-elf
+  HAL_TARGET:=armv4-le-elf$(if $(CONFIG_EABI_SUPPORT),gnueabi)
 endif
 ifneq ($(CONFIG_TARGET_atheros),)
   HAL_TARGET:=wisoc