[ar71xx] add dummy code for the Atheros AP83 board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Nov 2008 19:19:55 +0000 (19:19 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Nov 2008 19:19:55 +0000 (19:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13354 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/config-2.6.26
target/linux/ar71xx/config-2.6.27
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c [new file with mode: 0644]
target/linux/ar71xx/patches-2.6.26/001-ar71xx_core.patch
target/linux/ar71xx/patches-2.6.27/001-ar71xx_core.patch

index b59ba281bb1b1e2fcf10d0c204877eaa04202cb8..f360d28d3fbaa0fabcbd2ac216d795630445e085 100644 (file)
@@ -4,6 +4,7 @@ CONFIG_32BIT=y
 CONFIG_ADM6996_PHY=y
 CONFIG_AG71XX=y
 # CONFIG_AR71XX_EARLY_SERIAL is not set
+CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
index 8658bc99f9e7d663703734b502ff1fe4a03b3e1d..605a4ebee26cc0aa8af0f352b8ddba6a6edff1c2 100644 (file)
@@ -4,6 +4,7 @@ CONFIG_32BIT=y
 CONFIG_ADM6996_PHY=y
 CONFIG_AG71XX=y
 # CONFIG_AR71XX_EARLY_SERIAL is not set
+CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
 CONFIG_AR71XX_MACH_RB_4XX=y
index d8ae08577be00c3a6530709bee1958c1d2a46edc..3b11057a6b0c22e306de5183fe1bcaf6f152ada4 100644 (file)
@@ -6,6 +6,10 @@ config AR71XX_EARLY_SERIAL
 
 menu "Atheros AR71xx machine selection"
 
+config AR71XX_MACH_AP83
+       bool "Atheros AP83 board support"
+       default y
+
 config AR71XX_MACH_AW_NR580
        bool "AzureWave AW-NR580 board support"
        default y
index 175c43e911dab70834f48acf7707ba9710f5d5d5..dc682c8e57eb33394b17fb180f45aff99e1afa06 100644 (file)
@@ -10,6 +10,7 @@
 
 obj-y  := prom.o irq.o setup.o platform.o gpio.o ar71xx.o
 
+obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
 obj-$(CONFIG_AR71XX_MACH_RB_4XX)       += mach-rb-4xx.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap83.c
new file mode 100644 (file)
index 0000000..02e420a
--- /dev/null
@@ -0,0 +1,24 @@
+/*
+ *  Atheros AP83 board support
+ *
+ *  Copyright (C) 2008 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/platform_device.h>
+#include <linux/input.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+#include <asm/mach-ar71xx/pci.h>
+#include <asm/mach-ar71xx/platform.h>
+
+static void __init ap83_setup(void)
+{
+}
+
+MIPS_MACHINE(MACH_AR71XX_AP83, "Atheros AP83", ap83_setup);
index 0249c50080396f43b299b603571ff30846362197..c5871c8c5777139bb682c30d1d077c6a1c6516e4 100644 (file)
@@ -16,7 +16,7 @@
  
 --- a/include/asm-mips/bootinfo.h
 +++ b/include/asm-mips/bootinfo.h
-@@ -79,6 +79,17 @@
+@@ -79,6 +79,18 @@
  #define  MACH_LASAT_200               1       /* Masquerade PRO/SP200 */
  
  /*
@@ -29,6 +29,7 @@
 +#define MACH_AR71XX_RB_450    4       /* MikroTik RouterBOARD 450 */
 +#define MACH_AR71XX_RB_493    5       /* Mikrotik RouterBOARD 493/493AH */
 +#define MACH_AR71XX_AW_NR580  6       /* AzureWave AW-NR580 */
++#define MACH_AR71XX_AP83      7       /* Atheros AP83 */
 +
 +/*
   * Valid machtype for group NEC EMMA2RH
index 548c06b12da2f6d3dd0262c624f9fe6a50ec9937..1b1368bbc737abbad58052371b0a7f498456b552 100644 (file)
@@ -16,7 +16,7 @@
  
 --- a/include/asm-mips/bootinfo.h
 +++ b/include/asm-mips/bootinfo.h
-@@ -57,6 +57,17 @@
+@@ -57,6 +57,18 @@
  #define       MACH_MIKROTIK_RB532     0       /* Mikrotik RouterBoard 532     */
  #define MACH_MIKROTIK_RB532A  1       /* Mikrotik RouterBoard 532A    */
  
@@ -30,6 +30,7 @@
 +#define MACH_AR71XX_RB_450    4       /* MikroTik RouterBOARD 450 */
 +#define MACH_AR71XX_RB_493    5       /* MikroTik RouterBOARD 493 */
 +#define MACH_AR71XX_AW_NR580  6       /* AzureWave AW-NR580 */
++#define MACH_AR71XX_AP83      7       /* Atheros AP83 */
 +
  #define CL_SIZE                       COMMAND_LINE_SIZE