add prereq checks for the documentation (#1400)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 19:13:49 +0000 (19:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 19:13:49 +0000 (19:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6365 3c298f89-4303-0410-b956-a3cf2f4a3e73

docs/Makefile

index 359f4e63080dcfaf10a3fae2a5bb3c1a8eeb38dc..9e888a4af2df7fab545631ffe872b16106738ffb 100644 (file)
@@ -1,5 +1,12 @@
+ifeq ($(TOPDIR),)
+  TOPDIR:=${CURDIR}/..
+endif
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/prereq.mk
+
 MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
 
 all:
        $(MAKE) cleanup
@@ -7,6 +14,10 @@ all:
        $(MAKE) openwrt.pdf openwrt.html
        $(MAKE) cleanup
 
+.prereq:
+       $(MAKE) prereq
+       touch $@
+
 openwrt.html: $(DEPS)
        htlatex $(MAIN)
 
@@ -19,6 +30,12 @@ clean: cleanup
 cleanup: FORCE
        rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
+$(eval $(call RequireCommand,pdflatex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,htlatex, \
+       You need to install tex4ht to build the OpenWrt documentation \
+))
 
 FORCE:
 .PHONY: FORCE