new verbose/trace script for make
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jun 2006 17:14:34 +0000 (17:14 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jun 2006 17:14:34 +0000 (17:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4057 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/verbose.mk [new file with mode: 0644]

diff --git a/include/verbose.mk b/include/verbose.mk
new file mode 100644 (file)
index 0000000..77a877e
--- /dev/null
@@ -0,0 +1,25 @@
+# OpenWrt.org 2006
+# $Id:$
+
+ifeq ($(DUMP),)
+  ifndef KBUILD_VERBOSE
+    KBUILD_VERBOSE=0
+    ifeq ("$(origin V)", "command line")
+      KBUILD_VERBOSE=$(V)
+    endif
+  endif
+
+  ifeq ($(QUIET),1)
+    $(MAKECMDGOALS): trace
+    trace: FORCE
+       @[ -f "$(MAKECMDGOALS)" ] || { \
+               [ -z "$${PWD##$$TOPDIR}" ] || DIR=" -C $${PWD##$$TOPDIR/}"; \
+               echo -e "\33[33mmake[$$(($(MAKELEVEL)+1))]$$DIR $(MAKECMDGOALS)\33[m" >&3; \
+       }
+  else
+    export QUIET:=1
+    MAKE:=3>&1 4>&2 $(MAKE)
+  endif
+
+  .SILENT: $(MAKECMDGOALS)
+endif