Improve quilt patch handling: All quilt managed patches are checked before the packag...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Jun 2007 06:54:46 +0000 (06:54 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 3 Jun 2007 06:54:46 +0000 (06:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7472 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index ec5acc507e65a017db580f384c3dee26971388db..5fbdda1b9f8057b713b2ff8a3b0904a9b78c1842 100644 (file)
@@ -5,24 +5,27 @@
 # See /LICENSE for more information.
 #
 
-QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_patched && echo y))
+QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PREPARED:=$(strip $(STAMP_PREPARED))_q
+  STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
   CONFIG_AUTOREBUILD=
   PATCHES:=$(shell cd ./patches; ls)
   define Build/Patch/Default
        rm -rf $(PKG_BUILD_DIR)/patches
        mkdir -p $(PKG_BUILD_DIR)/patches
-       for patch in $(PATCHES); do ( \
+       @for patch in $(PATCHES); do ( \
                cp "./patches/$$$$patch" $(PKG_BUILD_DIR); \
                cd $(PKG_BUILD_DIR); \
                quilt import -p 1 "$$$$patch"; \
-               quilt push; \
-               quilt refresh; \
+               quilt push -f >/dev/null 2>/dev/null; \
                rm -f "$$$$patch"; \
        ); done
-       touch $(PKG_BUILD_DIR)/.quilt_patched
+       @echo
+       touch $(PKG_BUILD_DIR)/.quilt_used
   endef
+  $(STAMP_CONFIGURED): $(STAMP_PATCHED)
+  prepare: $(STAMP_PATCHED)
 else
   define Build/Patch/Default
        @if [ -d ./patches -a "$$$$(ls ./patches | wc -l)" -gt 0 ]; then \
@@ -31,6 +34,11 @@ else
   endef
 endif
 
+$(STAMP_PATCHED): $(STAMP_PREPARED)
+       @cd $(PKG_BUILD_DIR); quilt pop -a -f >/dev/null 2>/dev/null || true
+       cd $(PKG_BUILD_DIR); quilt push -a
+       touch $@
+
 refresh: $(STAMP_PREPARED)
        @[ -f "$(PKG_BUILD_DIR)/patches/series" ] || { \
                echo "The source directory was not unpacked using quilt. Please rebuild."; \