[backfire] merge r31267, r31268
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Apr 2012 23:09:39 +0000 (23:09 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Apr 2012 23:09:39 +0000 (23:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@31269 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/image-config.in
target/imagebuilder/Makefile
target/imagebuilder/files/repositories.conf

index 497b092d263055c9061067e0d4fff459681c9059..a9ec76a10bcc270213c242d963a911a7848f634f 100644 (file)
@@ -6,32 +6,32 @@
 #
 
 menuconfig PREINITOPT
 #
 
 menuconfig PREINITOPT
-     bool "Preinit configuration options" if IMAGEOPT
-     default n
-     help
-       These options are used to control the environment used to initialize
-       the system before running init (which typically mean /sbin/init which
-       switches to multiuser mode).
+       bool "Preinit configuration options" if IMAGEOPT
+       default n
+       help
+               These options are used to control the environment used to initialize
+               the system before running init (which typically mean /sbin/init which
+               switches to multiuser mode).
 
 config TARGET_PREINIT_SUPPRESS_STDERR
 
 config TARGET_PREINIT_SUPPRESS_STDERR
-      bool "Suppress stderr messages during preinit" if PREINITOPT
-      default y
-      help
-       Sends stderr to null during preinit.  This is the default behaviour
-       in previous versions of OpenWRT.  This also prevents init process
-       itself from displaying stderr, however processes launched by init
-       in multiuser through inittab will use the current terminal (e.g.
-       the ash shell launched by inittab will display stderr).  That's
-       the same behaviour as seen in previous version of OpenWRT.
+       bool "Suppress stderr messages during preinit" if PREINITOPT
+       default y
+       help
+               Sends stderr to null during preinit.  This is the default behaviour
+               in previous versions of OpenWRT.  This also prevents init process
+               itself from displaying stderr, however processes launched by init
+               in multiuser through inittab will use the current terminal (e.g.
+               the ash shell launched by inittab will display stderr).  That's
+               the same behaviour as seen in previous version of OpenWRT.
 
 config TARGET_PREINIT_TIMEOUT
 
 config TARGET_PREINIT_TIMEOUT
-       int
-       prompt "Failsafe wait timeout" if PREINITOPT
-       default 2
-       help
+       int
+       prompt "Failsafe wait timeout" if PREINITOPT
+       default 2
+       help
                How long to wait for failsafe mode to be entered before
                continuing with a regular boot if failsafe not selected.
                How long to wait for failsafe mode to be entered before
                continuing with a regular boot if failsafe not selected.
-               
+
 config TARGET_PREINIT_SHOW_NETMSG
        bool
        prompt "Show all preinit network messages" if PREINITOPT
 config TARGET_PREINIT_SHOW_NETMSG
        bool
        prompt "Show all preinit network messages" if PREINITOPT
@@ -42,7 +42,7 @@ config TARGET_PREINIT_SHOW_NETMSG
                if the architecture doesn't define an interface, and there is no
                'Preinit network interface' defined, then no messages will be
                emitted, even if this is set.
                if the architecture doesn't define an interface, and there is no
                'Preinit network interface' defined, then no messages will be
                emitted, even if this is set.
-               
+
 config TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG
        bool
        prompt "Suppress network message indicating failsafe" if PREINITOPT
 config TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG
        bool
        prompt "Suppress network message indicating failsafe" if PREINITOPT
@@ -54,90 +54,90 @@ config TARGET_PREINIT_SUPPRESS_FAILSAFE_NETMSG
                (via netmsg).
 
 config TARGET_PREINIT_IFNAME
                (via netmsg).
 
 config TARGET_PREINIT_IFNAME
-       string
-       prompt "Preinit network interface" if PREINITOPT
-       default ""
-       help
+       string
+       prompt "Preinit network interface" if PREINITOPT
+       default ""
+       help
                Interface for sending preinit messages to network, and any other
                default networking in failsafe or preinit.  If empty
                uses $ifname (if defined in /etc/preinit.arch).
 
 config TARGET_PREINIT_IP
                Interface for sending preinit messages to network, and any other
                default networking in failsafe or preinit.  If empty
                uses $ifname (if defined in /etc/preinit.arch).
 
 config TARGET_PREINIT_IP
-       string
-       prompt "IP address for preinit network messages" if PREINITOPT
-       default "192.168.1.1"
-       help    
-                      IP address used to configure interface for preinit network
-              messages, including failsafe messages
+       string
+       prompt "IP address for preinit network messages" if PREINITOPT
+       default "192.168.1.1"
+       help
+               IP address used to configure interface for preinit network
+               messages, including failsafe messages
 
 config TARGET_PREINIT_NETMASK
 
 config TARGET_PREINIT_NETMASK
-       string
-       prompt "Netmask for preinit network messages" if PREINITOPT
-       default "255.255.255.0"
-       help
-               Netmask used to configure interface for preinit network 
+       string
+       prompt "Netmask for preinit network messages" if PREINITOPT
+       default "255.255.255.0"
+       help
+               Netmask used to configure interface for preinit network
                messages, including failsafes messages
 
 config TARGET_PREINIT_BROADCAST
                messages, including failsafes messages
 
 config TARGET_PREINIT_BROADCAST
-       string
-       prompt "Broadcast address for preinit network messages" if PREINITOPT
-       default "192.168.1.255"
-       help
+       string
+       prompt "Broadcast address for preinit network messages" if PREINITOPT
+       default "192.168.1.255"
+       help
                Broadcast address to which to send preinit network messages, as
                as failsafe messages
 
 
 menuconfig INITOPT
                Broadcast address to which to send preinit network messages, as
                as failsafe messages
 
 
 menuconfig INITOPT
-    bool "Init configuration options" if IMAGEOPT
-    default n
-    help
-       These option choose the command that will run as the 'init' command
-       (that is which is responsible for controlling the system once preinit
-       transfers control to it) as well as some options controlling its
-       behaviour.  Normally init is /sbin/init.
-
-    config TARGET_INIT_PATH
-        string
-       prompt "PATH for regular boot" if INITOPT
-       default "/bin:/sbin:/usr/bin:/usr/sbin"
-       help
-               Default PATH used during normal operation
-
-    config TARGET_INIT_ENV
-        string
-           prompt "Environment variables to set when starting init (start with none)" if INITOPT
-           default ""
-           help
-               Should be a space seperated list of variable assignments.  These
-               variables will be present in the environment.  Spaces may not be
-               present (including through expansion) even in a quoted string
-               (env doesn't understanding quoting).
-
-    config TARGET_INIT_CMD
-        string
-           prompt "Init command" if INITOPT
-            default "/sbin/init"
-           help
-               The executable to run as the init process.  Is 'exec'd by
-               preinit (which is the init that the kernel launches on boot).
-
-    config TARGET_INIT_SUPPRESS_STDERR
-        bool
-        prompt "Suppress stderr messages of init" if INITOPT
-        default y
+       bool "Init configuration options" if IMAGEOPT
+       default n
        help
        help
-               Prevents showing stderr messages for init command if not already
-               suppressed during preinit.  This is the default behaviour in 
-               previous versions of OpenWRT.  Removing this does nothing if 
-               stderr is suppressed during preinit (which is the default).
+               These option choose the command that will run as the 'init' command
+               (that is which is responsible for controlling the system once preinit
+               transfers control to it) as well as some options controlling its
+               behaviour.  Normally init is /sbin/init.
+
+       config TARGET_INIT_PATH
+               string
+               prompt "PATH for regular boot" if INITOPT
+               default "/bin:/sbin:/usr/bin:/usr/sbin"
+               help
+                       Default PATH used during normal operation
+
+       config TARGET_INIT_ENV
+               string
+               prompt "Environment variables to set when starting init (start with none)" if INITOPT
+               default ""
+               help
+                       Should be a space seperated list of variable assignments.  These
+                       variables will be present in the environment.  Spaces may not be
+                       present (including through expansion) even in a quoted string
+                       (env doesn't understanding quoting).
+
+       config TARGET_INIT_CMD
+               string
+               prompt "Init command" if INITOPT
+               default "/sbin/init"
+               help
+                       The executable to run as the init process.  Is 'exec'd by
+                       preinit (which is the init that the kernel launches on boot).
+
+       config TARGET_INIT_SUPPRESS_STDERR
+               bool
+               prompt "Suppress stderr messages of init" if INITOPT
+               default y
+               help
+                       Prevents showing stderr messages for init command if not already
+                       suppressed during preinit.  This is the default behaviour in
+                       previous versions of OpenWRT.  Removing this does nothing if
+                       stderr is suppressed during preinit (which is the default).
 
 
 menuconfig VERSIONOPT
 
 
 menuconfig VERSIONOPT
-    bool "Version configuration options" if IMAGEOPT
-    default n
-    help
+       bool "Version configuration options" if IMAGEOPT
+       default n
+       help
                These options allow to override the version information embedded in
                These options allow to override the version information embedded in
-               the /etc/openwrt_version, /etc/openwrt_release, /etc/banner and 
+               the /etc/openwrt_version, /etc/openwrt_release, /etc/banner and
                /etc/opkg.conf files. Usually there is no need to set these, but
                they're useful for release builds or custom OpenWrt redistributions
                that should carry custom version tags.
                /etc/opkg.conf files. Usually there is no need to set these, but
                they're useful for release builds or custom OpenWrt redistributions
                that should carry custom version tags.
@@ -157,9 +157,9 @@ menuconfig VERSIONOPT
                        This is the release codename embedded in the image.
                        If unspecified, it defaults to the name of source branch.
 
                        This is the release codename embedded in the image.
                        If unspecified, it defaults to the name of source branch.
 
-    config VERSION_NUMBER
-        string
-       prompt "Release version number" if VERSIONOPT
+       config VERSION_NUMBER
+               string
+               prompt "Release version number" if VERSIONOPT
                help
                        This is the release version number embedded in the image.
                        If unspecified, it defaults to the svn or git-svn revision
                help
                        This is the release version number embedded in the image.
                        If unspecified, it defaults to the svn or git-svn revision
index 30083999e4e73f570f57005b12616bdf9f65ad1a..3d04656250857b0bd4d96adcdabbbce1f0faa780 100644 (file)
@@ -8,6 +8,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/host.mk
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/host.mk
+include $(INCLUDE_DIR)/version.mk
 
 override MAKEFLAGS=
 
 
 override MAKEFLAGS=
 
@@ -34,7 +35,7 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
                $(TMP_DIR)/.targetinfo \
                $(TMP_DIR)/.packageinfo \
                $(PKG_BUILD_DIR)/
                $(TMP_DIR)/.targetinfo \
                $(TMP_DIR)/.packageinfo \
                $(PKG_BUILD_DIR)/
-       $(SED) 's/$$A/$(BOARD)/' $(PKG_BUILD_DIR)/repositories.conf
+       $(VERSION_SED) $(PKG_BUILD_DIR)/repositories.conf
        $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
        $(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
        $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
        $(CP) $(PACKAGE_DIR) $(PKG_BUILD_DIR)/packages
        $(CP) $(STAGING_DIR_HOST)/bin $(PKG_BUILD_DIR)/staging_dir/host/
        $(CP) $(TOPDIR)/target/linux $(PKG_BUILD_DIR)/target/
index 4a55adb8590b1261a1b286c655316f1885beb343..708855eb8c3475929e3fb1dc3b63169cea477d51 100644 (file)
@@ -1,6 +1,6 @@
 ## Place your custom repositories here, they must match the architecture and version.
 ## Place your custom repositories here, they must match the architecture and version.
-# src/gz snapshots http://downloads.openwrt.org/snapshots/trunk/$A/packages
-# src custom file:///usr/src/openwrt/bin/$A/packages
+# src/gz %n %U
+# src custom file:///usr/src/openwrt/bin/%T/packages
 
 ## This is the local package repository, do not remove!
 src imagebuilder file:packages
 
 ## This is the local package repository, do not remove!
 src imagebuilder file:packages