add grub based images for x86-2.6 - still a bit hackish, but works with ext2 and...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Oct 2006 15:48:56 +0000 (15:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 8 Oct 2006 15:48:56 +0000 (15:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4962 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
target/image/x86/Config.in [new file with mode: 0644]
target/image/x86/Makefile
target/image/x86/gen_image.sh [new file with mode: 0755]
target/image/x86/grub/Makefile [new file with mode: 0644]
target/image/x86/grub/menu.lst [new file with mode: 0644]

index 7b28255fb5072e99e7f8b76d31df24f88d761832..74b3696242caf331aebf1df2d02f70cd53d2792e 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -90,6 +90,9 @@ menu "Target Images"
                help
                  Ext2 file system with some free space for uml images
 
+comment "Image Options"
+
+source "target/image/*/Config.in"
 
 endmenu
 
diff --git a/target/image/x86/Config.in b/target/image/x86/Config.in
new file mode 100644 (file)
index 0000000..fa61468
--- /dev/null
@@ -0,0 +1,20 @@
+config X86_GRUB_IMAGES
+       bool "Build GRUB images (Linux x86 or x86_64 host only)"
+       depends LINUX_2_6_X86
+       depends TARGET_ROOTFS_EXT2FS || TARGET_ROOTFS_JFFS2
+       default y
+
+config X86_GRUB_BAUDRATE
+       int "Serial port baud rate"
+       depends X86_GRUB_IMAGES
+       default 38400
+
+config X86_GRUB_KERNELPART
+       int "Kernel partition size (in MB)"
+       depends X86_GRUB_IMAGES
+       default 4
+
+config X86_GRUB_FSPART
+       int "Filesystem partition size (in MB)"
+       depends X86_GRUB_IMAGES
+       default 16
index 919ccbc9fe735fa6110c5d77ceff32010e9bd915..b836f3ace6f20a4e3635b8a5b361f2c4ae2e16e0 100644 (file)
@@ -7,9 +7,48 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+ifeq ($(CONFIG_X86_GRUB_IMAGES),y)
+  define Build/Compile
+       $(MAKE) -C grub compile
+  endef
+
+  define Build/Clean
+       $(MAKE) -C grub clean
+  endef
+
+  define Image/cmdline/jffs2-64k
+    block2mtd.block2mtd=/dev/hda2,65536 root=/dev/mtdblock0 rootfstype=jffs2
+  endef
+
+  define Image/cmdline/jffs2-128k
+    block2mtd.block2mtd=/dev/hda2,131072 root=/dev/mtdblock0 rootfstype=jffs2
+  endef
+
+  define Image/cmdline/ext2
+    root=/dev/hda2 rootfstype=ext2
+  endef
+
+  define Image/Build/grub
+       mkdir -p $(KDIR)/root.grub/boot/grub
+       $(CP) \
+               $(STAGING_DIR)/usr/lib/grub/i386-pc/stage1 \
+               $(STAGING_DIR)/usr/lib/grub/i386-pc/stage2 \
+               $(STAGING_DIR)/usr/lib/grub/i386-pc/e2fs_stage1_5 \
+               $(KDIR)/root.grub/boot/grub/
+       $(CP) $(LINUX_DIR)/arch/i386/boot/bzImage $(KDIR)/root.grub/boot/vmlinuz
+       sed \
+               -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)))#g' \
+               -e 's#@BAUDRATE@#$(CONFIG_X86_GRUB_BAUDRATE)#g' \
+               ./grub/menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
+       PATH="$(STAGING_DIR)/usr/sbin:$(STAGING_DIR)/bin:$(PATH)" ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).image $(CONFIG_X86_GRUB_KERNELPART) $(KDIR)/root.grub $(CONFIG_X86_GRUB_FSPART) $(KDIR)/root.$(1)
+  endef
+endif
+
 define Image/Build
-       cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+       $(call Image/Build/grub,$(1))
+       cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).fs
        cp $(LINUX_DIR)/arch/i386/boot/bzImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinuz
 endef
 
+
 $(eval $(call BuildImage))
diff --git a/target/image/x86/gen_image.sh b/target/image/x86/gen_image.sh
new file mode 100755 (executable)
index 0000000..3edce1e
--- /dev/null
@@ -0,0 +1,60 @@
+#!/bin/sh
+# Copyright (C) 2006 OpenWrt.org
+
+[ $# == 5 ] || {
+       echo "SYNTAX: $0 <file> <kernel size> <kernel directory> <rootfs size> <rootfs image>"
+       exit 1
+}
+
+file="$1"
+part1s="$2"
+part1d="$3"
+part2s="$4"
+part2f="$5"
+
+head=16
+sect=63
+cyl=$(( ($part1s + $part2s) * 1024 * 1024 / ($head * $sect * 512)))
+
+dd if=/dev/zero of="$file" bs=1M count=$(($part1s + $part2s))  2>/dev/null || exit
+fdisk -u -C $cyl -H $head -S $sect "$file" > /dev/null 2>/dev/null <<EOF
+n
+p
+1
+
++${part1s}M
+n
+p
+2
+
++${part2s}M
+w
+q
+EOF
+
+block() {
+       echo -e 'p\nq' | fdisk -u -C $cyl -H $head -S $sect "$file" | awk -v file="$file$1" -v n="$(($2 + 2))" '
+$1 == file {
+       print $n * 512
+}'
+}
+
+start="$(block 1 0)"
+end="$(block 1 1)"
+blocks="$(( ($end - $start) / 1024 ))"
+
+genext2fs -d "$part1d" -b "$blocks" "$file.kernel"
+dd if="$file.kernel" of="$file" bs=512 seek="$(($start / 512))" conv=notrunc
+rm -f "$file.kernel"
+
+start="$(block 2 0)"
+dd if="$part2f" of="$file" bs=512 seek="$(($start / 512))" conv=notrunc
+
+which chpax >/dev/null && chpax -zp $(which grub)
+grub --device-map=/dev/null <<EOF
+device (hd0) $file
+geometry (hd0) $cyl $head $sect
+root (hd0,0)
+setup (hd0)
+EOF
+
diff --git a/target/image/x86/grub/Makefile b/target/image/x86/grub/Makefile
new file mode 100644 (file)
index 0000000..86a9001
--- /dev/null
@@ -0,0 +1,58 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 4855 2006-09-24 20:49:31Z nico $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=grub
+PKG_VERSION:=0.97
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
+PKG_MD5SUM:=cd3f3eb54446be6003156158d51f4884
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/Configure
+       (cd $(PKG_BUILD_DIR); \
+               LDFLAGS="-static" \
+               ./configure \
+               --target=$(GNU_TARGET_NAME) \
+               --host=$(GNU_TARGET_NAME) \
+               --build=$(GNU_HOST_NAME) \
+               --program-prefix="" \
+               --program-suffix="" \
+               --prefix=/usr \
+               --exec-prefix=/usr \
+               --bindir=/usr/bin \
+               --sbindir=/usr/sbin \
+               --libexecdir=/usr/lib \
+               --sysconfdir=/etc \
+               --datadir=/usr/share \
+               --localstatedir=/var \
+               --mandir=/usr/man \
+               --infodir=/usr/info \
+               $(DISABLE_NLS) \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/InstallDev
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(STAGING_DIR)" \
+               install
+endef
+
+$(eval $(call Build/DefaultTargets))
diff --git a/target/image/x86/grub/menu.lst b/target/image/x86/grub/menu.lst
new file mode 100644 (file)
index 0000000..39803c5
--- /dev/null
@@ -0,0 +1,11 @@
+serial --unit=0 --speed=@BAUDRATE@ --word=8 --parity=no --stop=1
+terminal --timeout=10 serial
+
+default 0
+timeout 5
+
+title   OpenWrt
+root    (hd0,0)
+kernel  /boot/vmlinuz @CMDLINE@ noinitrd console=ttyS0,@BAUDRATE@n8
+boot
+