[package] dropbear: add GatewayPorts (-a) option (#6503)
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jan 2010 18:43:05 +0000 (18:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 14 Jan 2010 18:43:05 +0000 (18:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19127 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dropbear/Makefile
package/dropbear/files/dropbear.init

index 290addef0ef28a2137e674b25de86ed778fb378a..5a6ab3bbab51cd2f12f22e570149156f28b9e84b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dropbear
 PKG_VERSION:=0.52
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:= \
index 30cb44b1b151e309cdef616914625abe68c65bfb..36c37001c1f598d94c0713c9f97f5e339bf39298 100755 (executable)
@@ -38,10 +38,13 @@ dropbear_start()
        local bannerfile
        config_get bannerfile ${section} BannerFile
        [ -f $bannerfile ] || bannerfile=''
-
+       # D) gatewayports
+       local gatewayports
+       config_get_bool gatewayports "${section}" GatewayPorts 0
+       [ "${gatewayports}" -eq 1 ] || gatewayports=''
        # concatenate parameters
        local args
-       args="${nopasswd:+-s }${port:+-p ${port} }${bannerfile:+-b $bannerfile }-P /var/run/${NAME}.${PIDCOUNT}.pid"
+       args="${nopasswd:+-s }${port:+-p ${port} }${bannerfile:+-b $bannerfile }${gatewayports:+-a }-P /var/run/${NAME}.${PIDCOUNT}.pid"
 
        # execute program and return its exit code
        [ "${verbosed}" -ne 0 ] && echo "${initscript}: section ${section} starting ${PROG} ${args}"