fix parallel build issues
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Nov 2007 11:42:47 +0000 (11:42 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Nov 2007 11:42:47 +0000 (11:42 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9495 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/toplevel.mk

index b67413b887309808b09a877e39310452d096e565..e56535eac4e62aed6e01cf231714fe992b446a1b 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,8 +9,7 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
 
 world:
 
 
 world:
 
@@ -31,10 +30,13 @@ else
   include tools/Makefile
   include toolchain/Makefile
 
   include tools/Makefile
   include toolchain/Makefile
 
-$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(toolchain/stamp-install): $(tools/stamp-install)
 $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
 $(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
-$(package/stamp-compile): $(target/stamp-compile)
-$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
 
 $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
 
 $(BUILD_DIR)/.prepared: Makefile
        @mkdir -p $$(dirname $@)
index ba5cb33759b828f361266449832631aa4de6f738..7930223650c7e7cd372bb03b14fb727473c42269 100644 (file)
@@ -22,6 +22,7 @@ else
   endif
 endif
 export OPENWRTVERSION
   endif
 endif
 export OPENWRTVERSION
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
 
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build