add automake to tools/
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Dec 2007 00:27:32 +0000 (00:27 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Dec 2007 00:27:32 +0000 (00:27 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9901 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/automake/Makefile [new file with mode: 0644]

index fc3b2e175d1b21a12bbea77af94b31e17f7ea475..83244fa60939b88581319b1f5f4d90c5b21c6a0b 100644 (file)
@@ -9,7 +9,7 @@
 curdir:=tools
 
 # subdirectories to descend into
-$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config $(if $(CONFIG_CCACHE),ccache)
+$(curdir)/builddirs := sed sstrip ipkg-utils genext2fs squashfs mtd-utils lzma mkimage firmware-utils patch-cmdline pkg-config automake $(if $(CONFIG_CCACHE),ccache)
 
 # builddir dependencies
 $(curdir)/squashfs/compile := $(curdir)/lzma/install
diff --git a/tools/automake/Makefile b/tools/automake/Makefile
new file mode 100644 (file)
index 0000000..cf39cbd
--- /dev/null
@@ -0,0 +1,38 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=automake
+PKG_VERSION:=1.9.6
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@GNU/automake
+PKG_MD5SUM:=c11b8100bb311492d8220378fd8bf9e0
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+       $(call Build/Configure/Default,\
+               --datarootdir=$(STAGING_DIR_HOST)/share \
+       )
+endef
+
+define Build/Compile
+       $(MAKE) -C $(PKG_BUILD_DIR)
+endef
+
+define Build/Install
+       $(MAKE) -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+       $(MAKE) -C $(PKG_BUILD_DIR) uninstall
+       $(MAKE) -C $(PKG_BUILD_DIR) clean
+       $(call Build/Clean/Default)
+endef
+
+$(eval $(call HostBuild))