[adm5120] fix errors in image generation Makefiles, thanks to Thomas Langer (fixes...
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jul 2007 11:02:07 +0000 (11:02 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jul 2007 11:02:07 +0000 (11:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7904 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/adm5120-2.6/image/Makefile
target/linux/adm5120eb-2.6/image/Makefile

index 352ebf480f1e231fb4a1c381286065dbbc3b54dc..bf4ca5711b4a63b6f74908d47e5c60d812135696 100644 (file)
@@ -91,7 +91,7 @@ define Image/Build
 ifneq ($(1),jffs2-256k)
 ifneq ($(1),jffs2-128k)
        $(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
        $(call Image/Build/Edimax,$(1),br-6104kp,$(patsubst jffs2-%,jffs2,$(1)),BR-6104KP)
        $(call Image/Build/Edimax,$(1),br-6114wg,$(patsubst jffs2-%,jffs2,$(1)),BR-6114WG)
@@ -152,7 +152,7 @@ endef
 define Image/Build/Initramfs
        $(call Image/Build/Initramfs/RouterBoard)
        $(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/LZMAKernel/Generic,generic,bin)
        $(call Image/Build/LZMAKernel/Generic,np27g,bin)
        $(call Image/Build/LZMAKernel/Generic,wp54g,bin)
index 5772272090c2df0121df4d380920fbcf8ad500f9..7644a07ada383d7b4a4424239a6f690ec1b4e17d 100644 (file)
@@ -70,7 +70,7 @@ endef
 
 define Image/Build/Initramfs
 # this line is here intentionally
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/LZMAKernel/ZyXEL,p-334wt,bin)
        $(call Image/Build/LZMAKernel/ZyXEL,p-335,bin)
 endif