prevent verbose script from corrupting .pkginfo
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jun 2006 22:46:07 +0000 (22:46 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 23 Jun 2006 22:46:07 +0000 (22:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4067 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
include/verbose.mk

index a554a1d867fd3cd04d8aafc9e639e6f498a17e77..10652c07a33d56f76c0681df9223df9dcfc56a81 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -46,7 +46,7 @@ ifneq ($(shell ./scripts/timestamp.pl -p .pkginfo package Makefile),.pkginfo)
        @echo Collecting package info...
        @-for dir in package/*/; do \
                echo Source-Makefile: $${dir}Makefile; \
-               $(MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
+               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 2>&- || true; \
        done > $@
 endif
 
index 1ef403ccfb95a1bce23da75a178621bdf1722874..6d7c7ef6c16fd01f9b9a3413c494dced13114704 100644 (file)
@@ -2,17 +2,12 @@
 # $Id:$
 
 ifndef KBUILD_VERBOSE
-  ifeq ($(DUMP),)
-    KBUILD_VERBOSE=0
-  else
-    KBUILD_VERBOSE=99
-  endif
+  KBUILD_VERBOSE=0
   ifeq ("$(origin V)", "command line")
     KBUILD_VERBOSE=$(V)
   endif
 endif
 
-
 ifneq ($(KBUILD_VERBOSE),99)
   ifeq ($(QUIET),1)
     $(MAKECMDGOALS): trace
@@ -23,6 +18,7 @@ ifneq ($(KBUILD_VERBOSE),99)
        }
   else
     export QUIET:=1
+    NO_TRACE_MAKE:=$(MAKE) V=99
     ifeq ($(KBUILD_VERBOSE),0)
       MAKE:=&>/dev/null $(MAKE)
     endif