ar71xx: add missing flash partition for the DIR-825
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Jan 2010 13:35:25 +0000 (13:35 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 8 Jan 2010 13:35:25 +0000 (13:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19075 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/files/arch/mips/ar71xx/mach-dir-825-b1.c
target/linux/ar71xx/image/Makefile

index 7762b5cdc5f5cf64eab1b5cb04f5885912e6836a..80ab330844d72ef5348047002ead0bd9f93e57d4 100644 (file)
@@ -68,6 +68,11 @@ static struct mtd_partition dir825b1_partitions[] = {
                .offset         = 0x660000,
                .size           = 0x010000,
                .mask_flags     = MTD_WRITEABLE,
+       } , {
+               .name           = "unknown",
+               .offset         = 0x670000,
+               .size           = 0x190000,
+               .mask_flags     = MTD_WRITEABLE,
        }
 };
 #endif /* CONFIG_MTD_PARTITIONS */
index 94920a80309d9a7f5733043155534978af73b3b9..746f52576ece21c383e70a6b22689489649332b2 100644 (file)
@@ -77,7 +77,7 @@ define Image/Build/WRT400N
        fi; fi
 endef
 
-dir825b1_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,1024k(kernel),5184k(rootfs),64k(caldata)ro,6208k@0x50000(firmware)
+dir825b1_mtdlayout=mtdparts=spi0.0:256k(uboot)ro,64k(config)ro,1024k(kernel),5184k(rootfs),64k(caldata)ro,1600k(unknown)ro,6208k@0x50000(firmware)
 define Image/Build/DIR825B1
        $(call PatchKernelLzma,$(2),$(3) $(dir825b1_mtdlayout))
        $(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(call imgname,$(1),$(2)).bin)