fix dependencies on the virtual kernel package (fixes #878)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Oct 2006 14:02:33 +0000 (14:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Oct 2006 14:02:33 +0000 (14:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5279 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index 1ab85d4cc58a708be42c5c81363beef5b4e43826..2611828a3cc145db3115bd59d4d8bc37a3f0b6e0 100644 (file)
@@ -94,7 +94,7 @@ define KernelPackage
     CATEGORY:=Kernel modules
     DEFAULT:=m
     DESCRIPTION:=$(DESCRIPTION)
-    EXTRA_DEPENDS:='kernel (=$(PKG_VERSION)-$(PKG_RELEASE))'
+    EXTRA_DEPENDS:='kernel (=$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE))'
     $(call KernelPackage/$(1))
     $(call KernelPackage/$(1)/$(KERNEL))
     $(call KernelPackage/$(1)/$(BOARD)-$(KERNEL))