create some empty missing directories here
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Feb 2005 00:47:36 +0000 (00:47 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Feb 2005 00:47:36 +0000 (00:47 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@219 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index c2e628051aec229c9ac5d82e72f2d06b1d7573dc..81ecc43f8aa248fca2551734ec8ffc1e1d41f1db 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -107,6 +107,8 @@ $(STAGING_DIR):
 $(TARGET_DIR):
        @mkdir -p $(TARGET_DIR)
        cp -a target/default/target_skeleton/* $(TARGET_DIR)/
+       mkdir $(TARGET_DIR)/{proc,dev,jffs,tmp,usr/sbin}
+       chmod 1777 $(TARGET_DIR)/tmp
        -find $(TARGET_DIR) -type d -name CVS -exec rm -rf {} \; > /dev/null 2>&1
 
 source: $(TARGETS_SOURCE)