fix quilt patch check
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Oct 2007 17:58:12 +0000 (17:58 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Oct 2007 17:58:12 +0000 (17:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9121 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index daeef9431ffef66fbd5f36f56aedcbba49ec72b1..1b191ddcba962e3ae9f6d30ca0e63deca3e9a41b 100644 (file)
@@ -123,7 +123,7 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
        touch $@
 
 $(STAMP_CHECKED): $(STAMP_PATCHED)
-       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
+       if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt next >/dev/null 2>&1 && quilt push -a || quilt top >/dev/null 2>&1); fi
        touch $@
 
 define Build/Quilt