combine the 3 find in a single one
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Aug 2007 12:05:30 +0000 (12:05 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 24 Aug 2007 12:05:30 +0000 (12:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8477 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-ipkg.mk

index 597f5f87c350b5cd6d2f2b757affcd724fe10533..36f030375d1a16264d14202fbe839a0680a07907 100644 (file)
@@ -63,9 +63,7 @@ ifeq ($(DUMP),)
     $$(IPKG_$(1)): $(PKG_BUILD_DIR)/.built $$(IDIR_$(1))/CONTROL/control
        $(call Package/$(1)/install,$$(IDIR_$(1)))
        mkdir -p $(PACKAGE_DIR)
-       -find $$(IDIR_$(1)) -name CVS   | $(XARGS) rm -rf
-       -find $$(IDIR_$(1)) -name .svn  | $(XARGS) rm -rf
-       -find $$(IDIR_$(1)) -name '.#*' | $(XARGS) rm -f
+       -find $$(IDIR_$(1)) -name 'CVS' -o -name '.svn' -o -name '.#*' | $(XARGS) rm -rf
        $(RSTRIP) $$(IDIR_$(1))
        $(IPKG_BUILD) $$(IDIR_$(1)) $(PACKAGE_DIR)
        @[ -f $$(IPKG_$(1)) ] || false