fix host header files installation for tools (closes: #1604)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2007 22:23:33 +0000 (22:23 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 21 Apr 2007 22:23:33 +0000 (22:23 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7029 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile

index 31b0becc38e0e5cd0a424d723142e7164c2e96f2..513ecccb5197db32c2867b8cecbb12ad4636c7b1 100644 (file)
@@ -32,10 +32,11 @@ endif
 $(STAMP): $(TOPDIR)/.config
        mkdir -p $(shell dirname $@)
        touch $@
-       
-$(STAGING_DIR)/include-host:
-       @mkdir -p $@
-       @$(CP) ./include/*.h $@/
+
+TOOL_HOST_INCLUDES:=$(patsubst ./include/%.h,$(STAGING_DIR)/include-host/%.h,$(wildcard ./include/*.h))
+$(TOOL_HOST_INCLUDES): $(STAGING_DIR)/include-host/%.h: ./include/%.h
+       @mkdir -p $(STAGING_DIR)/include-host
+       $(CP) $< $@
 
 $(TOOL_BUILD_DIR):
        @mkdir -p $@
@@ -43,7 +44,7 @@ $(TOOL_BUILD_DIR):
 %-prereq %-download %-clean: FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
-%-prepare: $(STAGING_DIR)/include-host $(TOOL_BUILD_DIR) FORCE
+%-prepare: $(TOOL_HOST_INCLUDES) $(TOOL_BUILD_DIR) FORCE
        $(MAKE) -C $* $(patsubst $*-%,%,$@)
 
 %-compile: %-prepare FORCE