uClibc for x86 targets and kernels >= 2.6.24 need to copy the right include files...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Jul 2008 10:41:27 +0000 (10:41 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Jul 2008 10:41:27 +0000 (10:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11893 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/uClibc/Makefile

index 8c02489b1431d168a5519614ac61d9042d84435c..197f736d1e794fa5b6f127b4d239599a39a3de27 100644 (file)
@@ -64,6 +64,13 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
                -e 's/cris.*/cris/' \
 )
 
+# Remove me when there are no 2.6.23 targets
+ifeq ($(findstring 86,$(ARCH)),86)
+  ifneq ($(LINUX_2_6_23),y)
+       UCLIBC_TARGET_ARCH:=x86
+  endif
+endif
+
 define Build/Prepare/Snapshot
        $(PKG_UNPACK)
        rm -Rf $(PKG_BUILD_DIR)