generate package dependancies
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 May 2006 08:36:39 +0000 (08:36 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 May 2006 08:36:39 +0000 (08:36 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@3774 3c298f89-4303-0410-b956-a3cf2f4a3e73

scripts/gen_deps.pl [new file with mode: 0755]

diff --git a/scripts/gen_deps.pl b/scripts/gen_deps.pl
new file mode 100755 (executable)
index 0000000..d4b6c76
--- /dev/null
@@ -0,0 +1,34 @@
+#!/usr/bin/perl
+use strict;
+
+my $name;
+my $src;
+my $makefile;
+my %pkg;
+
+my $line;
+while ($line = <>) {
+       chomp $line;
+       $line =~ /^Source-Makefile: \s*(.+\/([^\/]+)\/Makefile)\s*$/ and do {
+               $makefile = $1;
+               $src = $2;
+       };
+       $line =~ /^Package: \s*(.+)\s*$/ and do {
+               $name = $1;
+               defined $pkg{$name} or $pkg{$name} = {};
+               $pkg{$name}->{src} = $src;
+       };
+       $line =~ /^Depends: \s*(.+)\s*$/ and do {
+               my @dep = split /,\s*/, $1;
+               $pkg{$name}->{depends} = \@dep;
+       };
+}
+
+foreach $name (sort {uc($a) cmp uc($b)} keys %pkg) {
+       print "$name: ";
+       foreach my $dep (@{$pkg{$name}->{depends}}) {
+               print "$dep ";
+       }
+       print "\n\tmake -C ".$pkg{$name}->{src}."\n";
+       print "\n";
+}