add /etc/passwd with an empty root password for dropbear
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Mar 2005 16:01:08 +0000 (16:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Mar 2005 16:01:08 +0000 (16:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@370 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dropbear/Makefile
package/dropbear/dropbear.conffiles [new file with mode: 0644]
package/dropbear/files/passwd [new file with mode: 0644]

index 62d802e9411d85d3a47e68458ea719981646a261..83558a33c274b9ed5f12ec0f99aca01c7001e8f3 100644 (file)
@@ -55,6 +55,7 @@ $(DROPBEAR_DIR)/$(DROPBEAR_BINARY): $(DROPBEAR_DIR)/.configured
 
 $(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
        $(SCRIPT_DIR)/make-ipkg-dir.sh $(DROPBEAR_IPK_DIR) dropbear.control $(DROPBEAR_VERSION)-1 $(ARCH)
+       cp dropbear.conffiles $(DROPBEAR_IPK_DIR)/CONTROL/conffiles
        mkdir -p $(DROPBEAR_IPK_DIR)/usr/bin
        mkdir -p $(DROPBEAR_IPK_DIR)/usr/sbin
        install -m 755 $(DROPBEAR_DIR)/$(DROPBEAR_BINARY) \
@@ -65,6 +66,7 @@ $(PACKAGE_DIR)/$(DROPBEAR_IPK): $(DROPBEAR_DIR)/$(DROPBEAR_BINARY)
        ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dropbearkey
        ln -sf ../sbin/dropbear $(DROPBEAR_IPK_DIR)/usr/bin/dropbearconvert
        mkdir -p $(DROPBEAR_IPK_DIR)/etc/init.d
+       cp ./files/passwd $(DROPBEAR_IPK_DIR)/etc
        cp ./files/S50dropbear $(DROPBEAR_IPK_DIR)/etc/init.d/
        chmod a+x $(DROPBEAR_IPK_DIR)/etc/init.d/S50dropbear
        $(IPKG_BUILD) $(DROPBEAR_IPK_DIR) $(PACKAGE_DIR)
diff --git a/package/dropbear/dropbear.conffiles b/package/dropbear/dropbear.conffiles
new file mode 100644 (file)
index 0000000..059086e
--- /dev/null
@@ -0,0 +1 @@
+/etc/passwd
diff --git a/package/dropbear/files/passwd b/package/dropbear/files/passwd
new file mode 100644 (file)
index 0000000..ae383d0
--- /dev/null
@@ -0,0 +1 @@
+root:$1$$qRPK7m23GJusamGpoGLby/:0:0:root:/tmp:/bin/ash