update zd1211 to r83, fix build on 2.6.19
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 15 Dec 2006 18:21:04 +0000 (18:21 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 15 Dec 2006 18:21:04 +0000 (18:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5802 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/zd1211/Makefile
package/zd1211/patches/101-linux_2.6.19_changes.patch [new file with mode: 0644]

index 0c152b975fae8a694683641e799db54aebdce1b5..841abb90b4d79018165335cc558e60f464e56d5f 100644 (file)
@@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=zd1211
-PKG_VERSION:=r69
+PKG_VERSION:=r83
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-driver-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=http://zd1211.ath.cx/download/
-PKG_MD5SUM:=c14133a3d5b27927402a492e84d2467a
+PKG_MD5SUM:=a5751f0e6f1f368689077fa7758a4932
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-driver-$(PKG_VERSION)
diff --git a/package/zd1211/patches/101-linux_2.6.19_changes.patch b/package/zd1211/patches/101-linux_2.6.19_changes.patch
new file mode 100644 (file)
index 0000000..7d80c8c
--- /dev/null
@@ -0,0 +1,46 @@
+diff -bruN zd1211-driver-r69-old/src/zd1205.c zd1211-driver-r69-new/src/zd1205.c
+--- zd1211-driver-r69-old/src/zd1205.c 2006-03-18 12:14:33.000000000 +0100
++++ zd1211-driver-r69-new/src/zd1205.c 2006-12-15 19:03:55.000000000 +0100
+@@ -31,7 +31,7 @@
+ * -------------------------------------------------------------------- */
+ #define __KERNEL_SYSCALLS__
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #include <net/checksum.h>
+ #include <linux/tcp.h>
+ #include <linux/udp.h>
+diff -bruN zd1211-driver-r69-old/src/zd1205_proc.c zd1211-driver-r69-new/src/zd1205_proc.c
+--- zd1211-driver-r69-old/src/zd1205_proc.c    2006-02-13 13:50:12.000000000 +0100
++++ zd1211-driver-r69-new/src/zd1205_proc.c    2006-12-15 19:04:02.000000000 +0100
+@@ -30,7 +30,7 @@
+ *
+ * -------------------------------------------------------------------- */
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #ifdef CONFIG_PROC_FS
+ #include "zd1205.h"
+diff -bruN zd1211-driver-r69-old/src/zd1211.c zd1211-driver-r69-new/src/zd1211.c
+--- zd1211-driver-r69-old/src/zd1211.c 2006-02-16 22:33:51.000000000 +0100
++++ zd1211-driver-r69-new/src/zd1211.c 2006-12-15 19:03:16.000000000 +0100
+@@ -30,7 +30,7 @@
+ *
+ * -------------------------------------------------------------------- */
+-#include <linux/config.h>
++#include <linux/autoconf.h>
+ #include <net/checksum.h>
+ #include <linux/tcp.h>
+ #include <linux/udp.h>
+@@ -1878,7 +1878,9 @@
+         dev->get_stats = zd1205_get_stats;
+ #if ZDCONF_WE_STAT_SUPPORT == 1
++# if WIRELESS_EXT < 21
+         dev->get_wireless_stats = zd1205_iw_getstats;
++# endif
+ #elif !defined(ZDCONF_WE_STAT_SUPPORT)
+       #error "Undefine ZDCONF_WE_STAT_SUPPORT"
+ #endif