add html output for the documentation (using tex4ht)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Jan 2007 13:15:57 +0000 (13:15 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 25 Jan 2007 13:15:57 +0000 (13:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6199 3c298f89-4303-0410-b956-a3cf2f4a3e73

docs/Makefile
docs/openwrt.tex

index 8c3ca646ddf757b967c0ba7f7111f89fc31616bb..359f4e63080dcfaf10a3fae2a5bb3c1a8eeb38dc 100644 (file)
@@ -1,14 +1,23 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+MAIN = openwrt.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+
+all:
        $(MAKE) cleanup
-       pdflatex openwrt.tex
-       pdflatex openwrt.tex
+       latex $(MAIN)
+       $(MAKE) openwrt.pdf openwrt.html
        $(MAKE) cleanup
+
+openwrt.html: $(DEPS)
+       htlatex $(MAIN)
+
+openwrt.pdf: $(DEPS)
+       pdflatex $(MAIN)
        
 clean: cleanup
-       rm -f openwrt.pdf
+       rm -f openwrt.pdf openwrt.html openwrt.css
 
 cleanup: FORCE
-       rm -f *.log *.aux *.toc *.out
+       rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
 
 FORCE:
index 753ac46e93ad0b0f9d60a33ccaed52034d8e7751..2c07052dac3816d51ebcd513449857bc1d154a2c 100644 (file)
@@ -1,6 +1,6 @@
 \documentclass[a4paper]{book}
 \usepackage[latin9]{inputenc}
-\usepackage[pdftex,bookmarks=true]{hyperref}
+\usepackage[bookmarks=true]{hyperref}
 \usepackage[T1]{fontenc}
 \usepackage{ae,aecompl,aeguill}
 \usepackage{fancyvrb}