make the compile: host-install dependency independent of the order in which the makef...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Mar 2009 14:07:08 +0000 (14:07 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 12 Mar 2009 14:07:08 +0000 (14:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14853 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index e92c7b3e68f33ec435d63a5357a2b5044ab83b88..a0ffd83b6e0bec3145a80f4b22741bfeb8b7bf42 100644 (file)
@@ -122,7 +122,7 @@ ifndef DUMP
     host-install: $(HOST_STAMP_INSTALLED)
   endif
 
-  download:
+  $(if $(STAMP_BUILT),compile: host-install)
   host-prepare: $(HOST_STAMP_PREPARED)
   host-configure: $(HOST_STAMP_CONFIGURED)
   host-compile: $(HOST_STAMP_BUILT)
@@ -134,8 +134,9 @@ ifndef DUMP
 
   endef
 
+  download:
   prepare: host-prepare
-  compile: host-compile $(if $(STAMP_BUILT),host-install)
+  compile: host-compile
   install: host-install
   clean: host-clean