[package] base-files: set rules file for hotplug2 in the boot script (closes #5235)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 May 2009 17:09:41 +0000 (17:09 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 30 May 2009 17:09:41 +0000 (17:09 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16215 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/boot

index 3bb809f43ce99668a9be5bdc72b4f1a30d22bb69..81d63d9ffd31a62669ce50c7d6e29c1a17b299c2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=21
+PKG_RELEASE:=22
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index 6ecddfb02243427f8145ef1e7c880277b318d8ed..283c02a1ae50b838cae4316bd74dfb194c8a41ac 100755 (executable)
@@ -53,6 +53,7 @@ start() {
        killall -q hotplug2
        [ -x /sbin/hotplug2 ] && /sbin/hotplug2 --override --persistent \
                        --set-worker /lib/hotplug2/worker_fork.so \
+                       --set-rules-file /etc/hotplug2.rules \
                        --max-children 1 >/dev/null 2>&1 &
 
        # the coldplugging of network interfaces needs to happen later, so we do it manually here