fix rootfs and init script handling
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 22:54:21 +0000 (22:54 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jul 2007 22:54:21 +0000 (22:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8293 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
package/Makefile

index 8a052674b4d5c9b14d64b688532dd341a78d7f93..e035faac2598135a8ce418c793e8ef349f81a600 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -48,7 +48,7 @@ distclean: dirclean
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks:
index 0d74c0d7f35bf9a2813dae20ff8c0ff6c4c25fcd..153ca657b0283b20dd105297e2150489d9bea8c0 100644 (file)
@@ -15,10 +15,11 @@ $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
 $(curdir)/builddirs-install:=. $(sort $(package-y))
 
 $(curdir)/install:=$(curdir)/install-cleanup
-$(curdir)/install-cleanup:
+
+$(curdir)/cleanup:
        rm -rf $(BUILD_DIR)/root
-       $(MAKE) install-targets
-       $(MAKE) preconfig
+
+$(curdir)/rootfs-prepare:
        @if [ -d $(TOPDIR)/files ]; then \
                $(CP) $(TOPDIR)/files/. $(BUILD_DIR)/root; \
        fi
@@ -33,16 +34,19 @@ $(curdir)/install-cleanup:
        @-find $(BUILD_DIR)/root -name CVS   | $(XARGS) rm -rf
        @-find $(BUILD_DIR)/root -name .svn  | $(XARGS) rm -rf
        @-find $(BUILD_DIR)/root -name '.#*' | $(XARGS) rm -f
-
-$(curdir)/index: FORCE
-       (cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
+       @(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages)
 
 $(curdir)/flags-install:= -j1
 
 $(eval $(call stampfile,$(curdir),package,prereq))
+$(eval $(call stampfile,$(curdir),package,cleanup))
 $(eval $(call stampfile,$(curdir),package,compile))
 $(eval $(call stampfile,$(curdir),package,install))
+$(eval $(call stampfile,$(curdir),package,rootfs-prepare))
 
-$($(curdir)/stamp-install): $($(curdir)/stamp-compile)
+$($(curdir)/stamp-cleanup): $(TMP_DIR)/.build
+$($(curdir)/stamp-compile): $($(curdir)/stamp-cleanup) $(TMP_DIR)/.build
+$($(curdir)/stamp-install): $($(curdir)/stamp-compile) $(TMP_DIR)/.build
+$($(curdir)/stamp-rootfs-prepare): $($(curdir)/stamp-install) $(TMP_DIR)/.build
 
 $(eval $(call subdir,$(curdir)))