Remove LINUX_2_6 dependency from qc-usb
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jan 2008 02:12:37 +0000 (02:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Jan 2008 02:12:37 +0000 (02:12 +0000)
This patch removes LINUX_2_6 dependency from qc-usb for those of us who
still have broadcom chipsets as qc-usb works fine on LINUX_2_4 too. This
compiles with both 2.4 and 2.6 kernels selected, and although i do not
have a Kamikaze svn system, the same changes (albeit without the new
package name changes in svn vs 7.09) work fine on my running 2.4 system
with a Quickcam Express card (older model).

Signed-off-by: Misha Koshelev <mk144210 at bcm dot edu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10123 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/qc-usb/Makefile

index 57f63941f0349898862dc22fa9d28b4acc210b97..ff41469b326d330f41b584a56619031024baa14f 100644 (file)
@@ -39,7 +39,7 @@ define KernelPackage/video-quickcam
 $(call Package/qc-usb/Default)
   SUBMENU:=Video Support
   TITLE:=QuickCam Express USB webcam support
-  DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-core kmod-video-core
+  DEPENDS:=@USB_SUPPORT +kmod-usb-core kmod-video-core
   FILES:=$(PKG_BUILD_DIR)/quickcam.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,90,quickcam)
 endef
@@ -49,13 +49,25 @@ define KernelPackage/video-quickcam/description
  with similar chipsets.
 endef
 
+ifeq ($(KERNEL),2.4)
+  ifeq ($(LINUX_KARCH),i386)
+    KERNEL_C_OPTS:= -Os -mpreferred-stack-boundary=2 -march=i486 -fno-unit-at-a-time
+  endif
+  ifeq ($(LINUX_KARCH),mips)
+    KERNEL_C_OPTS:= -Os -G 0 -mlong-calls -mno-abicalls -fno-pic -finline-limit=100000 -mabi=32 -march=mips32 -Wa,-32 -Wa,-march=mips32 -Wa,-mips32 -Wa,--trap
+  endif
+endif
+
 ifneq ($(CONFIG_PACKAGE_kmod-video-quickcam),)
   define Build/Compile/kmod
-       $(MAKE) -C $(LINUX_DIR) \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               LINUX_DIR="$(LINUX_DIR)" \
                ARCH="$(LINUX_KARCH)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
-               SUBDIRS="$(PKG_BUILD_DIR)" \
-               modules
+               CC="$(TARGET_CC)" \
+               LD="$(TARGET_CC) -nodefaultlibs -nostartfiles" \
+               USER_OPT="$(KERNEL_C_OPTS)" \
+               quickcam.$(LINUX_KMOD_SUFFIX)
   endef
 endif