install readelf to STAGING_DIR_HOST (eglibc requires it, not all systems have it)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 Jan 2009 04:54:25 +0000 (04:54 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 26 Jan 2009 04:54:25 +0000 (04:54 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14196 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/binutils/Makefile

index e6f60a846c293a06c0928579409eea2c7972370b..93d639220114b207f008eee72a7b1806388854e3 100644 (file)
@@ -24,6 +24,7 @@ endif
 
 PATCH_DIR:=./patches/$(PKG_VERSION)
 
+REAL_STAGING_DIR_HOST:=$(STAGING_DIR_HOST)
 STAGING_DIR_HOST:=$(TOOLCHAIN_DIR)
 BUILD_DIR_HOST:=$(BUILD_DIR_TOOLCHAIN)
 
@@ -62,6 +63,7 @@ endef
 
 define Build/Install
        $(MAKE) -C $(PKG_BUILD_DIR) install
+       $(CP) $(TOOLCHAIN_DIR)/usr/bin/$(REAL_GNU_TARGET_NAME)-readelf $(REAL_STAGING_DIR_HOST)/bin/readelf
 endef
 
 define Build/Clean