[backfire] merge r26968
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 May 2011 12:03:06 +0000 (12:03 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 May 2011 12:03:06 +0000 (12:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@26969 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iw/Makefile
package/iw/patches/110-fix_rate_calculation.patch [new file with mode: 0644]

index 625e17921be8e89980e7a2b74b9ffaeff73de7dc..2b714f8f9897a9bc17638d0a1999887dc46ecc65 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iw
 PKG_VERSION:=0.9.22
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://wireless.kernel.org/download/iw/
diff --git a/package/iw/patches/110-fix_rate_calculation.patch b/package/iw/patches/110-fix_rate_calculation.patch
new file mode 100644 (file)
index 0000000..e7328e3
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/ibss.c
++++ b/ibss.c
+@@ -104,7 +104,7 @@ static int join_ibss(struct nl80211_stat
+               if (*end != '\0')
+                       return 1;
+-              NLA_PUT_U32(msg, NL80211_ATTR_MCAST_RATE, (int) rate * 10);
++              NLA_PUT_U32(msg, NL80211_ATTR_MCAST_RATE, (int)(rate * 10));
+               argv++;
+               argc--;
+       }